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Introduction
Animal disease diagnosis involves a number of processes which 

include history taking, clinical examination and laboratory tests 
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Abstract

Objective: Small animal veterinary specialists and veterinary 
general practitioners from resource poor settings have a challenge 
in accessing information on canine diseases that can assist them 
understand further the differential diagnoses of the diseases. A 
simple consultant diagnostic searchable database that contains 
detailed information about specific canine diseases would be 
cardinal and greatly assist veterinarians in narrowing down and 
further understanding the differential diagnoses of canine infectious 
diseases. The objective of this study was to create a method for 
developing an Microsoft (MS) Excel-based searchable consultant 
diagnostic database that can be used by veterinarians in resource 
poor settings to assist in narrowing down the differential diagnoses. 

Methods: The tool was developed using excel visual basic for 
applications. In Microsoft excel Visual Basic for Applications, 
dynamic searchable drop-down combo boxes were created to 
enable users to key in clinical signs. Codes were written in modules 
in order to define macros that provided functionality for the “search” 
button to execute a search for the differential diagnosis.

Results: The database contains drop-down combo boxes for 
inputting clinical signs, a search button and cells for displaying the 
differential diagnosis. Each canine disease in the database can 
be summarized in terms of the aetiology, signs and symptoms, 
diagnosis, prevention, control and treatment. In addition, a list of 
references and hyperlinks can be provided which the veterinarian 
can consult for more information on each disease within the 
database.

Conclusion: This database will help in assisting veterinarians to 
easily access relevant information on the differential diagnosis of 
canine diseases. The usefulness of this searchable consultant 
diagnostic data base is discussed in relation to other consultant 
veterinary diagnostic databases. 
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where possible [1,2]. One of the central elements in the process of 
animal disease diagnosis is clinical examination. Clinical examination 
allows the veterinarian to acquire the information required to identify 
the disease or diseases causing the clinical abnormalities. A thorough 
and skillful clinical examination results in an accurate diagnosis which 
ensures effective treatment, control, prognosis and better welfare for 
the animal. The success of clinical examination relies heavily on the 
skills and knowledge of the veterinary clinician [2-5].

Sound knowledge of veterinary clinical diagnosticians should be 
aided by sound training as well asaccess to reliable clinical information. 
Information is considered to be a vital resource alongside land, labor, 
capital and skills [6]. Veterinarians need information for enhancing 
their diagnostic skills and for further understanding of animal 
diseases. 

Field veterinarians in resource poor settings usually have a 
challenge in accessing libraries and other sources of information such 
as text books and the internet. The veterinarian in resource-poor 
settings almost always rely entirely on information obtained from the 
patient’s history and clinical examination to arrive at their differential 
diagnoses. Lack of specialized diagnostic equipment means that 
veterinarians in resource-poor settings do not have the luxury of 
the various veterinary medical tests such as clinical chemistry, 
fluid analysis, hematology, histology, microbiology, serology and 
toxicology [7-9]. In addition, the veterinarians do not have access to 
textbooks and the internet to assist them to further understand and 
narrow down their differential diagnoses. As such the chances of 
misdiagnosing animal diseases are high. 

A simple consultant diagnostic database that contains information 
about specific canine diseases would be cardinal and greatly assist 
veterinarians in narrowing down and further understanding the 
differential diagnoses of canine infectious diseases. 

A number of veterinary consultant databases and informatics 
have been created for veterinarians before [10-12]. These consultant 
databases have been very valuable and useful. However, these 
databases are usually inaccessible to most veterinarians in resource 
poor settings where internet facilities are poor or unavailable. The 
desirable attributes of a computer-based diagnostic aid should include 
ease of use, ready accessibility, sound reasoning, completeness, the 
ability to justify its recommendations and a system for updating [12].

In this paper, I have proposed and provided the process for 
creating an MS excel-based diagnostic consultant tool that can be 
used mainly by veterinarians in resource poor settings to aid in the 
diagnosis process. 

Materials and Methods
Protocol for creating combo boxes with drop down lists.

Most of the steps for creating and operationalizing the drop down 
combo boxes were accessed from the Developer tab on MS excel 
ribbon. The Developer tab is usually not available on the excel ribbon 
but it can easily be accessed as follows:

File > Options > Customize Ribbon. In the Main tabs list, the 
Developer box can be checked followed by clicking OK. 
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1. Click Developer > Insert

a. Under From Controls, click list box (Form 
Control)

b. Select the cell where the combo box will appear

2. Click Properties > Control

a. In the Input range box, the range of cells from the 
clinical signs list was typed.

b. In the Cell link box, a cell reference for the 
combo box was typed. 

Creating the “SEARCH” button

In order to create and operationalize the “SEARCH” button, the 
MS excel visual basic for applications (VBA) was used [13-15]. In 
addition, standard excel formatting procedures were used to create the 
structure of thesearch button. The “developer” tab was selected from 
the MS Excel ribbon in order to access the VBAtool. MS excel VBA 
coding standard for writing macros was used to define the macros for 
the search button. In the VBA, a module (code window) was opened 
and the codes written for the search combo boxes and search button.

A number of MS Excel functions were used to create the searchable 
list and drop-down combo boxes [16-18]. The functions used were:

1. SEARCH Function

2. ISNUMBER

3. IF Function

4. MAX

5. ROWS

6. VLOOKUP

7. IFERROR

8. COUNTIF

9. OFFSET Function

10. FILTER

Results
The consultant diagnostic searchable dataset consists of three 

parts. The first part, is a worksheet that consists of a list of clinical 
signs and their associated infectious diseases. The second part is 
a worksheet named “SEARCH” (Figure 1) which consists of five 
dynamic drop-down combo boxes for keying in the clinical signs as 
determined by the veterinary clinician. The third part of the database 
consists of a number of worksheets each containing details about each 
infectious disease. Each of the worksheets contains details about each 
disease depicted under the following headings: description, etiology, 
transmission, clinical signs, diagnosis, prevention, treatment, 
references (Figure 2). The 35 worksheets and the CINICAL SIGNS 
worksheets are hidden from the user who only views the SEARCH 
worksheet. 

How the consultant diagnostic searchable database works

In this consultant database the clinician types in the clinical signs 
within the SEARCH worksheet. The drop-down combo boxes display 
the available clinical signs within the database according to the key 
words being typed in. Clicking the “SEARCH” button executes a 
macro (code) that instructs MS-excel to search for the keyed in 
clinical signs in the database and to display the differential diagnosis 
associated with those clinical signs. The differential diagnoses are 
displayed in hyperlinks so that when each is clicked, the user is taken 

Figure 1: Snapshot example of the “SEARCH” worksheet showing a list of clinical signs in drop down combo boxes, the SEARCH button and the output slot for 
the DIFFERENTIAL DIAGNOSIS. The user inputs (types in) the clinical signs in the drop down combo boxes and clicks on the “SEARCH” button. The results 
of the search are displayed under the DIFFERENTIAL DIAGNOSIS as a list of possible diseases matching the clinical signs. The differential diagnoses appear 
as hyperlinks which can be clicked to take the user to the worksheet that contains details on that disease. 
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A consultant diagnostic database can act as an adjunct to the 
diagnosis process. It has the potential to impact the diagnostic process 
in both positive and negative ways. When health IT tools support 
diagnostic team members and tasks in the diagnostic process and 
reflect human-centered design principles, health IT has the potential 
to improve diagnosis and reduce diagnostic errors [21].

Desirable attributes of a computer-based diagnostic aid should 
include: ease of use, ready accessibility, sound reasoning, completeness, 
the ability to justify its recommendations and a system for updating. 

The proposed MS excel database has many similarities to the 
internet based veterinary consultant diagnostic database [21] but 
there are a few differences too. The main difference is that this database 
will not require internet connectivity. In addition, the database is 
only focused on information on canine diseases as compared to the 
internet based databases that contain information on a number of 
animal species e.g. seven animal species in the case of [21]. 

The MS excel consultant diagnostic database will be relatively 
easy to use. Most veterinarians have a working knowledge of MS excel. 
Only a few steps will be required for the veterinarian to accomplish 
the task of searching the database.

Comparatively, this database will have more information on 
specific canine diseases as compared to the information found in 
the internet based databases. Most of the internet databases display 
only a few aspects of the differential diagnoses such as description, 
signs and references usually on a wide range of animal species. In this 
database, information is focused only on different aspects of canine 
diseases that include description, etiology, transmission, clinical signs, 
diagnosis, prevention, treatment and a list of relevant references.

In this database, information is provided about the general 
characteristics of each disease under the heading of “description”. Each 
disease is defined and its general characteristics provided in order for 
the veterinarian to quickly assess if the disease should be part of their 
differential diagnosis [22,23]. 

The biology, including the epidemiological distribution of the 
pathogens responsible for causing each of the diseases, are described 
in detail under the heading “etiology”. Other aspects of the diseases 

to another worksheet that contains detailed information on that 
particular disease. The steps involved in searching this database are 
as follows:

1. The user (veterinary clinician) after a thorough clinical 
investigation comes up with a list of clinical signs.

2. The veterinarian then opens the excel database from the 
desktop which displays the search worksheet. 

3. In the search worksheet, the user enters the appropriate 
clinical signs of the patient in the drop down combo boxes 
and then clicks on “SEARCH” button. 

4. A list of all possible clinical signs for the clinical signs is 
displayed under the DIFFERENTIAL DIAGNOSIS list.

5. The veterinarian can then click on any of the list of the 
differential diagnoses that appear as hyperlinks. 

6. After clicking on the hyperlink in the DIFFERENTIAL 
DIAGNOSIS list, the user is taken to another worksheet 
which contains more information about the selected 
disease. 

Discussion
Whether in animals or humans, getting the right diagnosis is a 

key aspect of health care [19]. In veterinary medicine, the diagnosis 
process is not very different from that in human medicine except 
the veterinarian usually deals with animals that cannot explain their 
symptoms. The diagnosis process is a complex, patient centered 
collaborative activity that involves information gathering and clinical 
reasoning with the goal of determining a patient’s health problem. It 
is a cyclical process of information gathering, information integration 
and interpretation. During the diagnosis process the clinician 
may refer or consult with other clinicians as part of the process of 
accumulating information that may be relevant to understanding a 
patient’s health problem. After information gathering, integration and 
interpretation, a hypothesis about the disease is generated that may 
lead to the development of a list of the likely causes of the disorder or 
what is known as the differential diagnosis [19,20].

Figure 2: Snapshot example of the differential diagnoses, in this case canine distemper. The worksheet contains details about the disease in terms of description, 
aetiology, transmission, clinical signs, diagnosis, prevention and treatment.



Citation: Simukoko H (2020) Method for Creating a Micrososoftexcel-based Consultantant Diagnostic Database for Canine Infectious Diseases. J Vet Sci Med 
Diagn 9:2.

• Page 4 of 4 •Volume 9 • Issue 2 • 100279

included in this database are the transmission, clinical signs, diagnosis, 
prevention and treatment thus giving the veterinary clinician a wider 
perspective on the disease. 

By using this database as a consultant diagnostic tool, 
veterinarians in resource poor settings can quickly refine their 
differential diagnoses. In addition, this database can also be used 
by researchers in small animal medicine to gather background 
information on canine diseases. 
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